Direct Debit Deposits Settlement Delay
Incident Report for Plum Fintech
Resolved
This incident has been resolved. All the affected transactions have been settled.

Rest assured that your funds are always safe with Plum.

We apologise for any inconvenience caused.
Posted Nov 05, 2024 - 13:13 GMT
Monitoring
The affected transactions have been settled. We are monitoring the results.

Once again, we apologise for any inconvenience this may have caused.

Rest assured your money is always safe with Plum.
Posted Nov 02, 2024 - 18:11 GMT
Investigating
We're aware that some customers might be experiencing a delay in completing their Direct Debit Deposits.

The issue is being investigated and worked on by our Tech Team with the highest priority.

Rest assured that your funds are always safe with Plum in the meantime.

We apologise for any inconvenience caused.
Posted Nov 02, 2024 - 10:10 GMT
This incident affected: ➡️ Deposits.