Deposits due 30 Oct delayed
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Oct 31, 2019 - 10:06 GMT
Identified
Due to operational issues deposits that were supposed to land 30 Oct have been delayed. We are very sorry about this and are working very hard to process them as quickly as possible. They should be in by tomorrow at the very latest.
Posted Oct 30, 2019 - 09:40 GMT
This incident affected: ➡️ Deposits.