Deposits due 15 July are delayed
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 18, 2019 - 11:12 BST
Investigating
Deposits that were due to arrive 15 July have been delayed. We do apologise for the inconvenience. They should arrive in your Plum account by tonight.
Posted 3 months ago. Jul 16, 2019 - 09:28 BST
This incident affected: ➡️ Deposits.