Delayed deposits
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Jan 12, 2020 - 10:40 GMT
Monitoring
Some customers with deposits due to settle yesterday evening may have seen minor delays with their funds arriving in their E-Wallet. Any customers with pending deposits as of this morning can expect the funds to be available within the next 4 hours. Please note this does not affect all Plumsters!
Posted Jan 11, 2020 - 11:05 GMT
This incident affected: ➡️ Deposits.