Roundups saver skipped
Incident Report for Plum Fintech
Resolved
The incident has been resolved and last week's roundups run successfully for all users yesterday. The saver is expected to run without disruptions in the future!

Thank you for bearing with us :)
Posted Jul 21, 2020 - 11:34 BST
Identified
An issue has been identified regarding the Roundups saver. The saver was skipped for some users since late June. The Tech Team is working to restore it for all users as soon as possible.
Posted Jul 21, 2020 - 08:35 BST
This incident affected: ➡️ Deposits.