Delayed deposits
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 29 days ago. Sep 24, 2019 - 14:48 BST
Identified
Due to technical issues in our system, deposits due in your Plum account from 19 September are delayed. We are working asap to resolve this issue. It should be in the Plum account by early next week, at the latest.
Posted about 1 month ago. Sep 20, 2019 - 15:29 BST
This incident affected: ➡️ Deposits.