Deposits due 2 Oct delayed
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 19 days ago. Oct 04, 2019 - 10:49 BST
Identified
Due to operational issues deposits that were supposed to land 2 October have been delayed. We are very sorry about this and are working very hard to process them as quickly as possible. They should be in by tomorrow, by the end of the day, at the very latest.
Posted 20 days ago. Oct 03, 2019 - 10:05 BST
This incident affected: ➡️ Deposits.