Chipotle (CMG) Stock Trading Restricted
Incident Report for Plum Fintech
Resolved
The incident has been resolved.

Chipotle (CMG) trading is re-enabled.

We apologize for any inconvenience this may have caused.
Posted Jul 08, 2024 - 11:44 BST
Identified
A message for stock investing customers:

Trading for Chipotle (CMG) shares has been temporarily restricted. This is due to the new prices not being available yet.

As soon as we have the new prices available, and the issue is resolved, trading will resume.

We're sorry for any inconvenience caused in the meantime.
Posted Jul 08, 2024 - 11:06 BST
This incident affected: 📈 Investments.