Partial outage of Partners
Incident Report for Plum Fintech
Resolved
The issue has been resolved by our partners. There are some minor delayed deposits but they will likely be reconciled into Plum accounts by the end of the day.
Posted 4 months ago. Jun 25, 2019 - 10:42 BST
Monitoring
Due to a European Peering Issue affecting the exchange of information between our partners, there may be a little disruption to deposits and withdrawals on 24.06.19
We are monitoring this closely and will update in due course.

You can follow up on the issue here: https://www.cloudflarestatus.com/
Posted 4 months ago. Jun 24, 2019 - 12:54 BST
This incident affected: ➡️ Deposits and ⬅️ Withdrawals.